My first full stack project is Bara, a single-page Yelp clone. After weeks of development and refactoring, I am pretty happy with the result. The UI looks good; the functionality works fine: users can sign up, log in, CRUD businesses and reviews.
Recently I’ve been reading Clean Code, and I begin to appreciate the importance of keeping the code clean. Programmers are authors; the code is like books we write, except our reader almost never begin to read from page 1. Usually the reader directly dives into a module/component to fix a problem or add a feature. To help the reader (could be your teammate, or even future you!), it is the author’s responsibility to make sure that the code is easy to read (and to change, but that’s another big topic). Martin Fowler said:
Any fool can write code that a computer can understand. Good programmers write code that humans can understand.
I decided to refactor Bara as a practice. The code works (the computer understands it), but it’s not clean. I did not intentionally make my code hard to read; I took care of indentations and whitespaces, but that code was far from clean. For example, the
Home component, which renders the homepage, looked like this:
Home component has three parts. From top to bottom, they are: 1.
HomeHero, which contains the
HomeBarContainer (login and signup links), the logo, the
FeaturedBusinesses, which is just three random businesses; 3.
Categories, which contains links to different businesses based on their categories. The core functionality of this page is that clicking on the logo changes
FeaturedBusinesses and the background image of
However, if my code were cleaner, not a single word in the previous paragraph would be necessary. The code can (and should) tell you what it does, explicitly, in a human-friendly way.
Here’s what I did to make the code cleaner:
Break down the component: only one level of abstraction per component. The
render method returns the three subcomponents:
Initially I only created
Categories component since it’s static, while
HomeHero has a
handleClick callback, and
FeaturedBusinesses has some extra logic. However, I can pass those information to the children as props, and this greatly cleans up the
render method. The
Home component does not have to know
HomeHero take care of those.
Break down the function: only one level of abstraction per function. For example, the original
handleClick does several things: it fetches featured businesses from the backend, saves them in the local state, and changes the background of
I group the first two things together since there is a logic connection between them, while changing the background is a totally separate issue. Therefore in the new
handleHomeLogoClick function, I call two functions to take care of each of them: 1. fetch and save featured functions; 2. update
HomeHero's background. Of course the first function can be further broken down.
The one level of abstraction rule gives the reader an option to ignore implementation details if he/she does not care. Overall, the logic is much more explicit, making the code less error-prone. Actually, after this refactoring, I found that in my old version of
componentDidMount, I shouldn’t update
HomeHero's background. In the new structure this bug becomes pretty obvious.
Use more descriptive names. The functions I mentioned in last section were named as
updateHomeHeroBackground, etc. Moreover, in the local state,
businesses field was renamed to
handleClick function was renamed to
handleHomeLogoClick. The extra information makes the code easier to understand (for humans!).
Conclusion: Write clean code. Your teammate and future you will thank you later. If you find this post interesting, make sure to check out Clean Code by Uncle Bob (disclaimer: I am not getting paid by anyone for doing this).
If you like what I write, let’s stay connected! Share the story, leave a response, or give some claps, thank you!